Email bounce handler
Incident Report for NamePros
Resolved
SendGrid has informed us that the issue has been resolved.
Posted about 1 month ago. Jun 21, 2018 - 13:51 UTC
Update
SendGrid has informed us that the issue has not been resolved on their end and has been escalated internally. Until we receive more information, we're continuing to manually review all bounce reports.
Posted about 1 month ago. Jun 19, 2018 - 19:08 UTC
Monitoring
SendGrid hasn't given us an update, but the issue appears resolved on our end. We'll continue monitoring this for a few days or until SendGrid informs us that's it's fixed.
Posted about 1 month ago. Jun 16, 2018 - 06:38 UTC
Update
SendGrid has confirmed that the issue is on there end, but has refused to update their status page.
Posted about 1 month ago. Jun 15, 2018 - 23:17 UTC
Identified
We've determined that we're receiving erroneous bounce events from SendGrid. The bug may exist on SendGrid's end, or it may be in our system that processes events. We're working with SendGrid to narrow down the issue.
Posted about 1 month ago. Jun 15, 2018 - 23:08 UTC
Update
Accounts that were marked as invalid have been restored to their original state. We're still investigating the cause of the issue. The email bounce handler remains disabled until we determine the cause.
Posted about 1 month ago. Jun 15, 2018 - 15:06 UTC
Investigating
Accounts with valid email addresses are erroneously being marked as invalid.
Posted about 1 month ago. Jun 15, 2018 - 14:49 UTC
This incident affected: Email (SendGrid: Invalid email handler, SendGrid: Email blacklist).