Queued emails failing
Incident Report for NamePros
Resolved
The issue has been fixed.

Forum and thread watch emails stopped around 17:48 UTC on 2021-08-23 when an update was applied. This resulted in about 20 hours of lost watch alert emails. If you were expecting such emails, the alerts from that gap will still be available from your alert feed and your news feed on the NamePros website.

The update attempted to enforce stricter security requirements on various types of data that we store in preparation for a future change we plan to make. While this was mostly successful, the mail queue for watch alert emails relies on a particular storage method that is incompatible with these newer requirements. We resolved the issue by excluding the mail queue's data from the new system.
Posted Aug 24, 2021 - 14:18 UTC
Monitoring
A fix has been implemented and we are monitoring the results.
Posted Aug 24, 2021 - 14:05 UTC
Identified
The issue has been identified and a fix is being implemented.
Posted Aug 24, 2021 - 14:05 UTC
Investigating
We've received reports that certain types of email alerts aren't being sent. We've confirmed that this isn't the case but haven't yet determined the cause. High-priority emails such as security alerts are still being sent.
Posted Aug 24, 2021 - 13:43 UTC
This incident affected: Email (SES: Primary outbound email system).