Email delivery failing
Incident Report for NamePros
Resolved
Though some emails will continue to bounce until we've finished the transition to SES, the transition has to be gradual, so we're marking this incident as resolved. We will re-open it if we encounter unexpected issues.
Posted 24 days ago. Jul 31, 2019 - 19:43 UTC
Update
SendGrid continues to insist that the issue is with our configuration and that the behavior on their end is expected, despite numerous attempts on our part to explain why that behavior clearly breaks DMARC according to section 4.2.1 of the DMARC specification. They have continued to insist that they cannot troubleshoot further without more information, even though we have sent them aggregate reports showing the problem very clearly.

We've notified SendGrid that we will be terminating our contract with them effective August 30, 2019. During the interim, we'll be transitioning to AWS SES gradually. We started sending 10% of emails through SES on Monday and will ramp up linearly, reaching 100% on August 29.
Posted 24 days ago. Jul 31, 2019 - 19:42 UTC
Monitoring
SendGrid has continued to insist that they don't have enough information to identify the issue. We're beginning the process of migrating away from SendGrid.

We'll be eliminating the invalid email handler for SendGrid, so that component is being marked as operational, since it's no longer relevant. It will be removed from our status page once the transition is complete.
Posted 26 days ago. Jul 29, 2019 - 19:22 UTC
Update
Despite numerous attempts to get SendGrid to respond to the issue, we still haven't been given any indication that anyone is working to resolve the issue. Their status page remains green. It's now been more than 48 hours since the issue started, so we're looking into switching to SES.
Posted 26 days ago. Jul 29, 2019 - 14:55 UTC
Identified
We've determined that SendGrid is authenticating a significant percentage of emails as being from sendgrid.net rather than namepros.com. SPF and DKIM are both passing for sendgrid.net, but our emails are sent from namepros.com.

SendGrid has still not indicated that they were able to resolve the issue.
Posted 28 days ago. Jul 28, 2019 - 02:31 UTC
Update
The rate of failures has increased despite disabling DMARC. We've disabled the invalid email handler, so no more accounts will be locked for the time being; this also means that marking a message from NamePros as "Spam" won't automatically unsubscribe you from emails until we've solved the issue.
Posted 28 days ago. Jul 27, 2019 - 19:00 UTC
Update
Accounts that were previously locked as a result of the issue have been unlocked. If you previously changed your email address to unlock your account, you can now change it back. It's still possible that emails will fail until the issue is fully resolved, but your account should not be locked if that happens.

As we've had to disable DMARC to work around this temporarily, you should take extra care to follow email security best practices when dealing with emails from NamePros until the issue is resolved.
Posted 28 days ago. Jul 27, 2019 - 17:55 UTC
Investigating
About 5% of emails are failing at the moment. We're in contact with SendGrid to resolve the issue. Some accounts may be automatically locked because the failed emails are being reported as hard bounces.
Posted 28 days ago. Jul 27, 2019 - 17:40 UTC
This incident affected: Email (SendGrid: Primary outbound email system, SendGrid: Invalid email handler).